Quijost

Por favor ingresa o regístrate.

Ingresar con nombre de usuario, contraseña y duración de la sesión
Búsqueda Avanzada  

Noticias:

Quijost.com - Hosting Gratis al alcance de tus manos

Autor Tema: Nota para usuarios Django  (Leído 8082 veces)

0 Usuarios y 1 Visitante están viendo este tema.

shakaran

  • Soporte
  • Administrator
  • Usuario profesional
  • *****
  • Karma: +12/-0
  • Desconectado Desconectado
  • Sexo: Masculino
  • Mensajes: 485
  • Un buen soporte lo es todo
    • Ver Perfil
    • Shakaran
Nota para usuarios Django
« en: Marzo 26, 2012, 16:37:47 pm »

Django 1.4 fue liberado el 23 de Marzo https://www.djangoproject.com/weblog/2012/mar/23/14/ y
actualizado en todos los servidores de Quijost el 25 de Marzo.

En el caso de esta actualización el cambio entre versiones rompe compatibilidades. Por lo que se ha
decidido dejar operativas ambas veriones, al menos durante un tiempo prudencial para que los clientes
dispongan de un tiempo y migrar sus sitios a la nueva versión de Django.

Los cambios que rompen compatibilidad y dejan obsoletas funcionalidades se encuentran listados en:
https://docs.djangoproject.com/en/dev/internals/deprecation/

Por un lado, recomendamos capturar las excepciones y tratarlas adecuadamente para no recibir errores 500.

Estos errores producidos y derivados de Django son responsabilidad del usuario, al igual que mantener su sitios
actualizados con las ultimas versiones estables de versiones de Django
que se ofrezcan.

El cambio puede resultar un poco abrupto de Django 1.3 a Django 1.4 y sobretodo cuando muchas funciones
no lanzan avisos de funciones obsoletas ("deprecated") y no mantienen retrocompatibilidad.

Nuestro problema también reside en que con más de 900 clientes es difícil satisfacer las condiciones a ofrecer respecto a versiones y software. No nos es posible ofrecer para el mismo binario de Python dos versiones diferentes de Django. Por otro lado cPanel tampoco facilita mucho las configuraciones con Python.

Para el binario de Python 2.7 (bajo /usr/local/bin/python y /usr/bin/python2.7) se ofrece Django 1.4. Pero cPanel y CentOS aún necesitan trabajar con Python 2.4 que usa (/usr/bin/python y /usr/bin/python2.4).

Si se desea seguir utilizando Django 1.3, deberá ser con el binario de Python 2.4 bajo /usr/bin/python2.4, pero recomendamos actualizar scripts a Django 1.4, ya que se prevee que cPanel y Centos pronto dejen obsoleto dicho binario y actualizarán a una version de Python mayor.

Puede comprobar la versión de Django disponible con:

Código: [Seleccionar]
# /usr/bin/python -c "import django; print django.get_version()"
1.3.1

Por otro lado, el próximo Django 1.5 sólo funcionara bajo versiones de Python 2.5 y superiores, por lo que sólo será posible ofrecerlo bajo Python2.7 en nuestros sistemas. Pronto ofreceremos también un binario con la versión de Python 3, lo que puede generar algunas incompatibilidades.

Les recomendamos seguirnos en facebook o twitter para estar enterado de próximas novedades al respecto.
« última modificación: Marzo 26, 2012, 18:27:56 pm por shakaran »
En línea
Ángel Guzmán Maeso
Quijost Founder - Backend Engineer & Main support

matusalen1

  • Usuario nuevo
  • *
  • Karma: +0/-0
  • Desconectado Desconectado
  • Mensajes: 1
    • Ver Perfil
Re:Nota para usuarios Django
« Respuesta #1 en: Mayo 11, 2012, 14:00:37 pm »

muchas gracias esta informacion me ha servido de ayuda
En línea
 

Página generada en 0.132 segundos con 24 consultas.