Quijost

Por favor ingresa o regístrate.

Ingresar con nombre de usuario, contraseña y duración de la sesión
Búsqueda Avanzada  

Noticias:

Deja tu post en el foro para hacer algun tipo de consulta

Mostrar Mensajes

Esta sección te permite ver todos los posts escritos por este usuario. Ten en cuenta que sólo puedes ver los posts escritos en zonas a las que tienes acceso en este momento.

Temas - ~Zant Corporation~

Páginas: [1]
1
Desarrollo Web / Pequeña duda sobre el mod_rewrite
« en: Octubre 13, 2012, 17:46:12 pm »
Hola a todos, vengo desde el soporte técnico de Quijost para plantear un problema que me ha surgido con mod_rewrite en el servidor compartido que tengo contratado.
Me gustaría redireccionar todos los archivos .js y .css hacia otra dirección. Sin embargo esto solo funciona cuando el archivo no existe, si este existe devuelve el archivo normal en lugar de redireccionarlo.
Este es el código que estoy usando en mi archivo .htaccess:

Código: [Seleccionar]
<IfModule mod_rewrite.c>
  RewriteEngine On
  RewriteBase /
  RewriteRule ^([^/.]+)$ $1.php [L]
  RewriteCond %{REQUEST_URI} !^.*jquery.*$
  RewriteCond %{REQUEST_FILENAME} -F
  RewriteRule ^(.*\.)(js|css)$ /min/?f=$1$2
</IfModule>
Nótese que uso el parámetro -F para comprobar si el archivo existe.

En un servidor local con WAMP funciona perfectamente, sin embargo en Quijost no. No estoy seguro pero creo que puede deberse al cacheado de archivos que usan, el cual puede estar devolviendo los archivos de su caché en lugar de volver a hacer la petición.

¿Podrían ofrecerme alguna solución a esto?
Saludos!

Páginas: [1]

Página generada en 0.361 segundos con 21 consultas.